Supported browsers

Browser compatibility

Hannah Chapple avatar
Written by Hannah Chapple
Updated over a week ago

Satchel One works best when used with the latest versions of Chrome, Firefox, Edge, Safari, or Internet Explorer.

Download the latest versions of these browsers by clicking on an icon below:

Did this answer your question?